Python使用pip安装TensorFlow模块 – jack_Meng

1.先确保已经安装,然后使用pip安装模块。

2.进入cmd窗口,建议执行-m pip -U pip升级。

3.如果之前安装过numpy,需要先卸载之前安装的,因为每个都有对应的numpy版本,所以卸载之前的numpy

4.然后输入-m pip –自动安装,系统会自动下载安装包。

命令提交后,你唯一能做的就是等待。你唯一能祈祷的是这个该死的***不会毁了你的好东西。还好这次我很幸运,一下子就搞定了。

验证安装

在桌面创建一个.py文件,编写如下代码

import tensorflow as tf
import os
os.environ['TF_CPP_MIN_LOG_LEVEL']= '2'
hello = tf.constant('Hello, TensorFlow!')
sess = tf.Session()
print(sess.run(hello))

图片[1]-Python使用pip安装TensorFlow模块 – jack_Meng-唐朝资源网

a
= tf.constant(10) b = tf.constant(25) print(sess.run(a + b))

参考:

Win10安装注意事项:

[] 64位安装-官方原生支持:

安装步骤如下:

安装教程:

学习:

珠虎:

极客:

异常处理:

以下是从网上找到的,其他人在安装过程中出现的错误或异常,以及解决方法:

图片[2]-Python使用pip安装TensorFlow模块 – jack_Meng-唐朝资源网

之后直接pip,安装后自动安装了numpy,但是报错。因为我之前自己用过numpy,早就安装好了。并且每个都有对应的numpy版本,所以之前需要卸载numpy。解决方法如下

1.:

(最后一次通话):

……

:[Errno 13]

:’D:\\\Lib\site-\numpy\core\.cp36-.pyd’

解决方法:关闭所有正在运行的程序

2. :numpy, -,

找到:numpy 1.11.3

numpy-1.11.3:

……

无法卸载 numpy

解决方案:pip — numpy

来源:

================================================ === =============

0.12.0 安装在支持下

环境要求:安装过程:.5

python.exe -m pip install --upgrade pip

安装

pip install --upgrade tensorflow

pip install --upgrade tensorflow-gpu

gpu版本安装gpu支持包安装cuda8.0 .1

添加解压后的bin目录到PATH环境变量

测试

$ python
...

>>> import tensorflow as tf
>>> hello = tf.constant('Hello, TensorFlow!')
>>> sess = tf.Session()
>>> print(sess.run(hello))
b'Hello, TensorFlow!'
>>> a = tf.constant(10)
>>> b = tf.constant(32)
>>> print(sess.run(a + b))
42
>>>

如果报错,需要下载安装C++ 2015

还要确认CUDA CUDNN是否与版本匹配

nvidia-smi -l # 实时返回GPU使用情况

来源:

© 版权声明
THE END
喜欢就支持一下吧
点赞11 分享
评论 抢沙发
头像
欢迎您留下宝贵的见解!
提交
头像

昵称

取消
昵称表情代码图片